Get in touch
Back
Degraded

New Server + big software update for Clipflip Studio -> resulted in some SSL errors

Started 19 Sep at 03:07pm CEST, resolved 19 Sep at 03:42pm CEST.

Clipflip Studio
Resolved

All back to normal! Thanks for your patience and your trust!

Posted 19 Sep at 03:42pm CEST.
Created

Due to the change to a new server infrastructure and a big software update for Clipflip Studio, the performance may have been affected on some devices. We are sorry for the inconvenience. We now have more power and better reliability to host and create your interactive videos. We hope you like it!

Thank you for your understanding!

Best
Jakob Sturm

Posted 19 Sep at 03:07pm CEST.